Appendice: Dependency matrix

Using Transmorpher requires several freely available software:

The current version of Transmorpher uses the following version of these software (some other configurations also works, this is not exhaustive):

SoftwareBrandVersion minVersion max testedJar
Java VMSun JDK1.31.5
SAX/JAXPOasis2.0/1.1
XML parserApache Xerces2.1
XSLT processorApache Xalan2.4
Regular expressionsgnu.regexp1.1.31.1.4gnu-regexp-1.1.3.jar
Servlet serverJakarta Tomcat4.0.45.5.17

Other extensions of Transmorpher might require external software as indicated in their description.

Compatibility table for former Transmorpher versions:
DateVersionJavaParserXSLTgnu.regexpServeltNote
10/03/20071-0-7 1.5inJavainJava1.1.34.0.4
26/02/20041-0-6 1.3Xerces 2.1Xalan 2.41.1.34.0.4INRIA Free Software CDROM 2004
24/02/20041-0-5 1.3Xerces 2.1Xalan 2.41.1.34.0.4
14/02/20031-0-3 1.3Xerces 2.1Xalan 2.41.1.34.0.4
03/02/20031-0-2 1.3Xerces 2.1Xalan 2.41.1.34.0.4
10/12/20021-0-1 1.3Xerces 2.1Xalan 2.41.1.34.0.4
08/11/20021-0-0 1.3Xerces 2.1Xalan 2.41.1.34.0.4
18/10/20020-9-11 1.3Xerces 2.1Xalan 2.41.1.34.0.4
16/10/20020-9-10 1.3Xerces 2.1Xalan 2.41.1.34.0.4
08/07/20020-9-9 1.3Xerces 1.3Xalan 2.11.1.3-
06/06/20020-9-8 1.3Xerces 1.3Xalan 2.11.1.3-
20/12/20010-9-7 1.3Xerces 1.3Xalan 2.11.1.3-INRIA Free Software CDROM 2002
12/12/20010-9-6 1.3Xerces 1.3Xalan 2.11.1.3-
04/12/20010-9-5 1.3Xerces 1.3Xalan 2.11.1.3-
21/06/20010-9-1 1.3Xerces 1.3Xalan 2.0--
13/06/20010-9-0 1.3Xerces 1.3Xalan 2.0--
22/05/200120010522 1.3Xerces 1.3Xalan 2.0--

Next chapter: DTD


http://transmorpher.gforge.inria.fr/refman/depend.html

Feel free to comment to Jérôme:Euzenat#inrialpes:fr, $Id: depend.html,v 1.19 2007/03/10 20:37:04 euzenat Exp $